Redistribusi RIPv2, OSPF dan EIGRP

Network

Balik lagi ke latihan konfigurasi routing protokol.

Btw, sebelumnya gue mau ngucapin selamat beribadah puasa bagi yang menjalankannya. Semoga ibadah puasa kita dapat diterima dan menjadi berkah untuk semua umat. Pastinya juga kita jangan sampai melewatkan sepuluh hari terakhir untuk mendapat malam lailatul qodar, yaitu malam 1000 bulan (bukan 1001 malam, lho, hehe). Konon barangsiapa mendapatkan malam tersebut insya Allah dosa-dosanya selama delapan puluh tahun akan diampuni oleh Allah SWT. Amin..

Kembali berkutat dengan GNS 3.

Pada saat postingan ini dibuat, GNS 3 merilis versi terbarunya, yaitu versi 0.84. Dari sisi fitur gue nggak ngecek tapi dari sisi tampilan memang ada perubahan, diantaranya ikon-ikon di menu bar. Well, that’s for smoothing only I think.

Kita punya topologi seperti gambar di bawah.

ScreenShot467

Mungkinkah ada topologi semacam tersebut di dalam network production? tentu saja! Berbagai macam tipe jenis routing protokol digunakan asal sesuai dengan standar routing protocol itu tidak akan menjadi sebuah masalah. Contoh kongkret di dalam network production biasanya terdapat berbagai macam jenis dan tipe perangkat. Mulai dari variasi switch huawei, cisco, hingga router alcatel lucent dan juniper. Asal mereka menggunakan tipe interface physical yang sama, jenis encapsulasi layer 2 yang serupa dan jenis routing protocol layer 3 yang sesuai standar, mereka semua akan mampu berkomunikasi dan saling bertukar data satu sama lain.

Langsung ke konfigurasi. Pertama seperti biasa kita berikan IP pada setiap interface router sesuai dengan aturan pada gambar. Kemudian atur routing protocol pada router HQ agar menjalankan RIPv2 dan EIGRP. Router JKT menjalankan RIPv2 dan OSPF, serta router BDG menjalankan OSPF dan EIGRP. Atur parameter sesuai dengan topologi. Jangan lupa note pada gambar juga harus diperhatikan.

Berikut hasil konfigurasi router HQ:

!
hostname HQ
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
ip address 10.1.13.1 255.255.255.252
serial restart-delay 0
!
interface Ethernet1/0
ip address 10.1.110.1 255.255.255.252
half-duplex
!
router eigrp 13
network 10.0.0.0
no auto-summary
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
no auto-summary
!
no ip http server
ip classless
!
end      

Kemudian konfigurasi router JKT:

!
hostname JKT
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 10.1.12.2 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
ip address 10.1.23.2 255.255.255.252
serial restart-delay 0
!
interface Ethernet1/0
ip address 10.1.24.1 255.255.255.252
half-duplex
!
router ospf 100
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.23.0 0.0.0.3 area 0
!
router rip
version 2
network 10.0.0.0
!
end

Dan terakhir router BDG:

hostname BDG
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
ip address 10.1.13.2 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
ip address 10.1.23.1 255.255.255.252
serial restart-delay 0
!
interface Ethernet1/0
ip address 10.1.37.1 255.255.255.252
half-duplex
!
router eigrp 13
network 3.0.0.0
network 10.0.0.0
auto-summary
!
router ospf 100
log-adjacency-changes
network 10.1.23.0 0.0.0.3 area 0
!
end

Berikut kita coba lakukan PING dari masing-masing router ke loopback address tetangganya. Seharusnya hasilnya adalah gagal karena belum ada path control yang mengatur distribusi antar routing protokol alias Redsitribusi. Fitur ini adalah fitur standar yang digunakan dalam dunia per-protokolan supaya komunkasi antar routing protokol dapat terjalin.

Nah, mari kita coba lakukan redistribusi untuk soal kali ini. Caranya adalah dengan me-redistribusi RIP ke dalam EIGRP pada router HQ, OSPF ke dalam RIP pada router JKT dan EIGRP ke OSPF pada router BDG.

Berikut adalah konfigurasi redistribusi untuk router HQ.

!
router eigrp 13
redistribute rip metric 10000 100 255 1 1500
network 10.0.0.0
no auto-summary
!

Kemudian untuk router JKT.

!
router rip
version 2
redistribute ospf 100 metric transparent
network 10.0.0.0
!

Dan terakhir untuk router BDG.

!
router ospf 100
log-adjacency-changes
redistribute eigrp 13 subnets
network 10.1.23.0 0.0.0.3 area 0
!

Finally kita coba lakukan PING dari masing-masing router ke loopback tetangganya and you’ll see it’s gonna work!🙂

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s